Sync Outage affecting some customers
Minor incident
Desktop Sync
iPhone/iPad Sync
2025-04-09 08:33 EDT
· 2 hours, 8 minutes
Updates
Monitoring
April 9, 2025 · 09:36 EDT
✅ Fix Implemented - Monitoring
A fix has been implemented for the issue. We are closely monitoring the situation to ensure full stability.
We will provide a final update once we confirm that everything is back to normal.
Issue
April 9, 2025 · 08:33 EDT
🚨 Investigating
We are currently investigating an issue. Our team is actively looking into the root cause.
Thank you for your patience. We will provide updates as soon as possible.
← Back