Billings Pro Outage
Major incident
Desktop Sync
iPhone/iPad Sync
Numbering Service
Documents Service
Control Panel
Currency Service
2026-05-10 16:06 EDT
· 7 hours, 21 minutes
Updates
Resolved
May 10, 2026 · 23:27 EDT
🎉 Incident Resolved
The issue has been fully resolved. All services are now back to normal.
Thank you for your patience, and we appreciate your understanding. If you experience any further issues, please contact support.
Monitoring
May 10, 2026 · 20:40 EDT
The problem has been corrected. All systems are operational. Monitoring now.
Issue
May 10, 2026 · 16:06 EDT
🚨 Investigating
We are currently investigating an issue. Our team is actively looking into the root cause.
Thank you for your patience. We will provide updates as soon as possible.
← Back